<!doctype html><html lang="en" xml:lang="en" xmlns="http://www.w3.org/1999/xhtml" prefix="og: http://ogp.me/ns#" data-reactroot=""><head><meta data-react-helmet="true" name="application-name" content="Someecards" /><meta data-react-helmet="true" charSet="utf-8" /><meta data-react-helmet="true" http-equiv="X-UA-Compatible" content="IE=edge" /><meta data-react-helmet="true" name="robots" content="/robots.txt" /><meta data-react-helmet="true" property="fb:app_id" content="32911495680" /><meta data-react-helmet="true" property="fb:pages" content="122560544447547,103280435790,354522044588660" /><meta data-react-helmet="true" name="p:domain_verify" content="b9b60a9aacefcae0b6992526093f59b8" /><meta data-react-helmet="true" name="viewport" content="width=device-width, initial-scale=1" /><meta data-react-helmet="true" name="theme-color" content="#eeeeee" /><meta data-react-helmet="true" name="msapplication-TileColor" content="#eeeeee" /><meta data-react-helmet="true" name="msapplication-TileImage" content="/favicons/mstile-144x144.png" /><meta data-react-helmet="true" name="msapplication-square70x70logo" content="/favicons/mstile-70x70.png" /><meta data-react-helmet="true" name="msapplication-square150x150logo" content="/favicons/mstile-150x150.png" /><meta data-react-helmet="true" name="msapplication-wide310x150logo" content="/favicons/mstile-310x150.png" /><meta data-react-helmet="true" name="msapplication-square310x310logo" content="/favicons/mstile-310x310.png" /><meta data-react-helmet="true" name="description" content="18 people with &#x27;I want to talk to your manager&#x27; parents reveal their most embarrassing moments." /><meta data-react-helmet="true" name="keywords" content="18,people with &#x27;I want to talk to your manager&#x27; parents reveal their most embarrassing moments.,News" /><meta data-react-helmet="true" property="og:title" content="18 people with &#x27;I want to talk to your manager&#x27; parents reveal their most embarrassing moments." /><meta data-react-helmet="true" property="og:description" content="18 people with &#x27;I want to talk to your manager&#x27; parents reveal their most embarrassing moments." /><meta data-react-helmet="true" property="og:url" content="https://www.someecards.com/news/news/18-people-with-i-want-to-talk-to-your-manager-parents-reveal-their-most-embarrassing-moments/" /><meta data-react-helmet="true" property="og:type" content="article" /><meta data-react-helmet="true" property="og:image" content="https://cdn.someecards.com/posts/18-people-with-i-want-to-talk-to-your-manager-parents-reveal-their-most-embarrassing-moments-RhK.jpg" /><meta data-react-helmet="true" name="twitter:card" content="summary_large_image" /><meta data-react-helmet="true" name="twitter:url" content="https://www.someecards.com/news/news/18-people-with-i-want-to-talk-to-your-manager-parents-reveal-their-most-embarrassing-moments/" /><meta data-react-helmet="true" name="twitter:title" content="18 people with &#x27;I want to talk to your manager&#x27; parents reveal their most embarrassing moments." /><meta data-react-helmet="true" name="twitter:image" content="https://cdn.someecards.com/posts/18-people-with-i-want-to-talk-to-your-manager-parents-reveal-their-most-embarrassing-moments-RhK.jpg" /><meta data-react-helmet="true" name="twitter:description" content="18 people with &#x27;I want to talk to your manager&#x27; parents reveal their most embarrassing moments." /><meta data-react-helmet="true" property="article:publisher" content="https://www.facebook.com/someecards" /><title data-react-helmet="true">18 people with &#x27;I want to talk to your manager&#x27; parents reveal their most embarrassing moments. | Someecards News</title><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="57x57" href="/favicons/apple-touch-icon-57x57.png" /><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="114x114" href="/favicons/apple-touch-icon-114x114.png" /><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="72x72" href="/favicons/apple-touch-icon-72x72.png" /><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="144x144" href="/favicons/apple-touch-icon-144x144.png" /><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="60x60" href="/favicons/apple-touch-icon-60x60.png" /><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="120x120" href="/favicons/apple-touch-icon-120x120.png" /><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="76x76" href="/favicons/apple-touch-icon-76x76.png" /><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="152x152" href="/favicons/apple-touch-icon-152x152.png" /><link data-react-helmet="true" rel="icon" type="image/png" href="/favicons/favicon-196x196.png" sizes="196x196" /><link data-react-helmet="true" rel="icon" type="image/png" href="/favicons/favicon-96x96.png" sizes="96x96" /><link data-react-helmet="true" rel="icon" type="image/png" href="/favicons/favicon-32x32.png" sizes="32x32" /><link data-react-helmet="true" rel="icon" type="image/png" href="/favicons/favicon-16x16.png" sizes="16x16" /><link data-react-helmet="true" rel="icon" type="image/png" href="/favicons/favicon-128.png" sizes="128x128" /><link data-react-helmet="true" rel="mask-icon" href="/favicons/favicon.svg" color="black" /><link data-react-helmet="true" rel="manifest" href="/manifest.json" /><link data-react-helmet="true" rel="search" type="application/opensearchdescription+xml" title="Someecards" href="https://cdn.someecards.com/assets/xml/someecards-search-v1.xml" /><link data-react-helmet="true" rel="stylesheet" href="//cdnjs.cloudflare.com/ajax/libs/bulma/0.5.3/css/bulma.min.css" /><link data-react-helmet="true" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat:200,300,400" /><link data-react-helmet="true" rel="amphtml" href="https://www.someecards.com/news/news/18-people-with-i-want-to-talk-to-your-manager-parents-reveal-their-most-embarrassing-moments/amp" /><link data-react-helmet="true" rel="canonical" href="https://www.someecards.com/news/news/18-people-with-i-want-to-talk-to-your-manager-parents-reveal-their-most-embarrassing-moments/" /><link href="https://assets.someecards.com/build/client/index-0168d14ae884e4afca94e89f9a18c17c.css" media="screen, projection" rel="stylesheet" type="text/css" /><style data-react-helmet="true">#page-wrapper {background-color: white;}</style><style type="text/css" data-styled-components="eMLfYp ibslFo PjpiJ hSsjZP fKTuzN XmMvk fZAMVg drPxLX iWOpDh hnDJMw gXgRDr hfPQQH cysacG eiymfV cEGIXa SJmpU kFUWuI cKVznk cJGMHE" data-styled-components-is-local="true">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</style></head><body><div id="fb-root"></div><div id="app"><div data-reactroot=""><div class="PageWrapper-s1ohzv1j-0 fKTuzN" id="page-wrapper"><div></div><div class="Header__HeaderWrapper-s1d4y3ad-0 XmMvk"><div class="container"><div class="menu-container"><div class="Menu__MenuWrapper-s1f8v837-0 fZAMVg"><div class="menu-icon"><span>☰</span></div><div class="NavigationWrapper-s197hs89-0 drPxLX" id="navigation-wrapper"><div class="shadow"></div><div class="navigation-content-container"><div class="navigation-content-inner-container"><div class="item-row top"><div class="share-icons-container columns is-mobile"><div class="column valign-center"><div class="ShareIcon__ShareIconWrapper-tu12x0-0 iWOpDh"><a href="https://facebook.com/someecards" target="_blank"><svg fill="currentColor" preserveAspectRatio="xMidYMid meet" height="1em" width="1em" viewBox="0 0 40 40" style="vertical-align:middle"><g><path d="m29.4 0.3v5.9h-3.5q-1.9 0-2.6 0.8t-0.7 2.4v4.2h6.6l-0.9 6.6h-5.7v16.9h-6.8v-16.9h-5.7v-6.6h5.7v-4.9q0-4.1 2.3-6.4t6.2-2.3q3.3 0 5.1 0.3z"></path></g></svg></a></div></div><div class="column valign-center"><div class="ShareIcon__ShareIconWrapper-tu12x0-0 iWOpDh"><a href="https://twitter.com/someecards" target="_blank"><svg fill="currentColor" preserveAspectRatio="xMidYMid meet" height="1em" width="1em" viewBox="0 0 40 40" style="vertical-align:middle"><g><path d="m37.7 9.1q-1.5 2.2-3.7 3.7 0.1 0.3 0.1 1 0 2.9-0.9 5.8t-2.6 5.5-4.1 4.7-5.7 3.3-7.2 1.2q-6.1 0-11.1-3.3 0.8 0.1 1.7 0.1 5 0 9-3-2.4-0.1-4.2-1.5t-2.6-3.5q0.8 0.1 1.4 0.1 1 0 1.9-0.3-2.5-0.5-4.1-2.5t-1.7-4.6v0q1.5 0.8 3.3 0.9-1.5-1-2.4-2.6t-0.8-3.4q0-2 0.9-3.7 2.7 3.4 6.6 5.4t8.3 2.2q-0.2-0.9-0.2-1.7 0-3 2.1-5.1t5.1-2.1q3.2 0 5.3 2.3 2.4-0.5 4.6-1.7-0.8 2.5-3.2 3.9 2.1-0.2 4.2-1.1z"></path></g></svg></a></div></div><div class="column valign-center"><div class="ShareIcon__ShareIconWrapper-tu12x0-0 iWOpDh"><a href="https://pinterest.com/someecards" target="_blank"><svg fill="currentColor" preserveAspectRatio="xMidYMid meet" height="1em" width="1em" viewBox="0 0 40 40" style="vertical-align:middle"><g><path d="m37.3 20q0 4.7-2.3 8.6t-6.3 6.2-8.6 2.3q-2.4 0-4.8-0.7 1.3-2 1.7-3.6 0.2-0.8 1.2-4.7 0.5 0.8 1.7 1.5t2.5 0.6q2.7 0 4.8-1.5t3.3-4.2 1.2-6.1q0-2.5-1.4-4.7t-3.8-3.7-5.7-1.4q-2.4 0-4.4 0.7t-3.4 1.7-2.5 2.4-1.5 2.9-0.4 3q0 2.4 0.8 4.1t2.7 2.5q0.6 0.3 0.8-0.5 0.1-0.1 0.2-0.6t0.2-0.7q0.1-0.5-0.3-1-1.1-1.3-1.1-3.3 0-3.4 2.3-5.8t6.1-2.5q3.4 0 5.3 1.9t1.9 4.7q0 3.8-1.6 6.5t-3.9 2.6q-1.3 0-2.2-0.9t-0.5-2.4q0.2-0.8 0.6-2.1t0.7-2.3 0.2-1.6q0-1.2-0.6-1.9t-1.7-0.7q-1.4 0-2.3 1.2t-1 3.2q0 1.6 0.6 2.7l-2.2 9.4q-0.4 1.5-0.3 3.9-4.6-2-7.5-6.3t-2.8-9.4q0-4.7 2.3-8.6t6.2-6.2 8.6-2.3 8.6 2.3 6.3 6.2 2.3 8.6z"></path></g></svg></a></div></div><div class="column valign-center"><div class="ShareIcon__ShareIconWrapper-tu12x0-0 iWOpDh"><a href="https://instagram.com/someecards" target="_blank"><svg fill="currentColor" preserveAspectRatio="xMidYMid meet" height="1em" width="1em" viewBox="0 0 40 40" style="vertical-align:middle"><g><path d="m33.4 31.8v-14.4h-3q0.4 1.4 0.4 2.9 0 2.8-1.4 5.2t-3.9 3.7-5.3 1.4q-4.4 0-7.6-3t-3.1-7.3q0-1.5 0.5-2.9h-3.2v14.4q0 0.6 0.4 1t1 0.4h23.8q0.6 0 1-0.4t0.4-1z m-6.3-11.9q0-2.7-2.1-4.7t-4.8-1.9q-2.9 0-4.9 1.9t-2 4.7 2 4.8 4.9 1.9q2.8 0 4.8-1.9t2.1-4.8z m6.3-8v-3.7q0-0.6-0.4-1.1t-1.1-0.4h-3.9q-0.7 0-1.1 0.4t-0.5 1.1v3.7q0 0.6 0.5 1.1t1.1 0.4h3.9q0.6 0 1.1-0.4t0.4-1.1z m3.9-4.6v25.4q0 1.9-1.3 3.1t-3.1 1.3h-25.5q-1.8 0-3.1-1.3t-1.3-3.1v-25.4q0-1.9 1.3-3.1t3.1-1.3h25.5q1.8 0 3.1 1.3t1.3 3.1z"></path></g></svg></a></div></div></div><div class="close-button-container valign-center"><svg fill="currentColor" preserveAspectRatio="xMidYMid meet" height="1em" width="1em" viewBox="0 0 40 40" style="vertical-align:middle"><g><path d="m31.6 10.7l-9.3 9.3 9.3 9.3-2.3 2.3-9.3-9.3-9.3 9.3-2.3-2.3 9.3-9.3-9.3-9.3 2.3-2.3 9.3 9.3 9.3-9.3z"></path></g></svg></div></div><div class="header-row top"><a href="/">Articles</a></div><div class="item-row"><a href="/">Home</a></div><div class="item-row"><a href="/news">News</a></div><div class="item-row"><a href="/entertainment">Entertainment</a></div><div class="item-row"><a href="/life">Lifestyle</a></div><div class="item-row"><a href="/memes-lists-comics">Memes / Lists / Comics</a></div><div class="header-row"><a href="/memes/all">Ecards</a></div><div class="item-row"><a href="/memes/all">Newest &amp; Popular</a></div><div class="item-row"><a href="/card/categories/">More...</a></div><div class="header-row">Brand Partners</div><div class="item-row"><a href="/name-a-roach">Name A Roach</a></div><div class="header-row">Store</div><div class="item-row"><a href="https://www.somewinecompany.com/" target="_blank">SomeWine</a></div><div class="item-row"><a href="https://amzn.to/2yZsKiy" target="_blank">Someecards Products</a></div><div class="header-row">Company</div><div class="item-row"><a href="/page/about">About</a></div><div class="item-row"><a href="/page/contact">Contact</a></div><div class="item-row"><a href="/page/press">Press</a></div><div class="item-row"><a href="/page/advertise">Advertise</a></div><div class="item-row"><a href="/newsletter/subscribe">Newsletter</a></div><div class="item-row"><a href="/page/jobs">Jobs</a></div><div class="header-row">Legal</div><div class="item-row"><a href="/page/terms">Terms of Use</a></div><div class="item-row"><a href="/page/privacy">Privacy Policy</a></div><div class="item-row"><a href="/page/dmca">DMCA</a></div><div class="footer-container"><hr /><p>©Someecards</p></div></div></div></div></div></div><div class="logo-container"><a href="/"><img id="top-logo" src="https://assets.someecards.com/build/client/f56e171e5f10ff0ce8b5e42ae3a6cac3.png" alt="Someecards Logo" /></a></div><div class="search-container"><a href="/search"><svg fill="currentColor" preserveAspectRatio="xMidYMid meet" height="1em" width="1em" viewBox="0 0 40 40" style="vertical-align:middle"><g><path d="m27.2 18.6q0-4.2-2.9-7.1t-7.1-2.9-7 2.9-3 7.1 2.9 7 7.1 3 7.1-3 2.9-7z m11.4 18.5q0 1.2-0.8 2.1t-2 0.8q-1.2 0-2-0.8l-7.7-7.7q-4 2.8-8.9 2.8-3.2 0-6.1-1.3t-5-3.3-3.4-5-1.2-6.1 1.2-6.1 3.4-5.1 5-3.3 6.1-1.2 6.1 1.2 5 3.3 3.4 5.1 1.2 6.1q0 4.9-2.7 8.9l7.6 7.6q0.8 0.9 0.8 2z"></path></g></svg></a></div></div></div><div class="site-container"><div class="PostWrapper-f8jrk3-0 kFUWuI"><div class="column ad-row full-width leaderboard"><span style="font-size:0"></span></div><div class="post-wrapper-outer"><div class="post-wrapper-inner"><div class="post-left-outer"><div class="PostHeader__PostHeaderWrapper-s18qja9r-0 cKVznk"><div class="title-container"><h1 class="post-title">18 people with &#x27;I want to talk to your manager&#x27; parents reveal their most embarrassing moments.</h1></div><div class="LazyImg__LazyImgWrapper-s5co4mu-0 hnDJMw"><div class="image-container"><img class="lazy-image is-loaded" src="https://cdn.someecards.com/posts/18-people-with-i-want-to-talk-to-your-manager-parents-reveal-their-most-embarrassing-moments-smT.jpg" alt="18 people with &#x27;I want to talk to your manager&#x27; parents reveal their most embarrassing moments." /></div></div><div class="post-meta-container"><div class="users-container"><a href="/author/kimberadin">Kimberly Dinaro</a></div><div class="date-container"><span><span>Mar 14, 2019</span><span class="at-symbol">@</span><span>6:11 PM</span></span></div><div class="share-container"><div class="ShareButton__ShareButtonWrapper-feylio-1 cJGMHE"><div class="main-share-container valign-center"><div role="button" tabindex="0" class="SocialMediaShareButton SocialMediaShareButton--facebook"><div style="width:50px;height:50px"><svg viewBox="0 0 64 64" fill="white" width="50" height="50" class="social-icon social-icon--facebook "><g><rect width="64" height="64" fill="#3b5998" style="fill:transparent"></rect></g><g><path d="M34.1,47V33.3h4.6l0.7-5.3h-5.3v-3.4c0-1.5,0.4-2.6,2.6-2.6l2.8,0v-4.8c-0.5-0.1-2.2-0.2-4.1-0.2 c-4.1,0-6.9,2.5-6.9,7V28H24v5.3h4.6V47H34.1z"></path></g></svg></div></div><div role="button" tabindex="0" class="SocialMediaShareButton SocialMediaShareButton--twitter"><div style="width:50px;height:50px"><svg viewBox="0 0 64 64" fill="white" width="50" height="50" class="social-icon social-icon--twitter "><g><rect width="64" height="64" fill="#00aced" style="fill:transparent"></rect></g><g><path d="M48,22.1c-1.2,0.5-2.4,0.9-3.8,1c1.4-0.8,2.4-2.1,2.9-3.6c-1.3,0.8-2.7,1.3-4.2,1.6 C41.7,19.8,40,19,38.2,19c-3.6,0-6.6,2.9-6.6,6.6c0,0.5,0.1,1,0.2,1.5c-5.5-0.3-10.3-2.9-13.5-6.9c-0.6,1-0.9,2.1-0.9,3.3 c0,2.3,1.2,4.3,2.9,5.5c-1.1,0-2.1-0.3-3-0.8c0,0,0,0.1,0,0.1c0,3.2,2.3,5.8,5.3,6.4c-0.6,0.1-1.1,0.2-1.7,0.2c-0.4,0-0.8,0-1.2-0.1 c0.8,2.6,3.3,4.5,6.1,4.6c-2.2,1.8-5.1,2.8-8.2,2.8c-0.5,0-1.1,0-1.6-0.1c2.9,1.9,6.4,2.9,10.1,2.9c12.1,0,18.7-10,18.7-18.7 c0-0.3,0-0.6,0-0.8C46,24.5,47.1,23.4,48,22.1z"></path></g></svg></div></div><div class="more-share-container valign-center"><a><svg fill="currentColor" preserveAspectRatio="xMidYMid meet" height="1em" width="1em" viewBox="0 0 40 40" style="vertical-align:middle"><g><path d="m21.7 9.2c-0.5 0-0.9 0.1-1.2 0.5-0.3 0.3-0.5 0.7-0.5 1.1v4.3c-7.5 0.8-13.3 7.2-13.3 14.9v1.7c3.7-5.7 8.7-6.6 13.3-6.7v4.2c0 0.4 0.2 0.8 0.5 1.1s0.7 0.5 1.2 0.5 0.8-0.1 1.1-0.5l10.5-10.3-10.5-10.3c-0.3-0.4-0.7-0.5-1.1-0.5z"></path></g></svg></a></div></div></div></div></div></div><div class="post-content-container"><span></span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p>It might be embarrassing to have your parents pay to <a href="https://www.someecards.com/news/news/lori-loughlin-felicity-huffman-affidavit-criminal-complaint/">cheat your way into a top college</a>, but having your parents yell at an innocent retail or restaurant worker is definitely up there. </p><div class="oembedall-container sec-iframe sec-oembed-iframe"><iframe src="https://giphy.com/embed/yoJC2wgHpObWKxMpjO" width="245" height="245" frameBorder="0" class="giphy-embed" allowfullscreen=""></iframe></div><p>Even though you&#x27;d think that most people would have a sense of empathy and be kind to people in the trenches of department stores and restaurants, most of the time people who have had the luxury of never working these jobs feel entitled. Whether it&#x27;s throwing a temper tantrum about there not being enough lemons in a free tap water, trying to cut the line or complain their way into free stuff--it&#x27;s always something. </p> <div class="special-placement-container"><div id="t-special-placement"></div></div> <div class="oembedall-container sec-iframe sec-oembed-iframe"><iframe src="https://giphy.com/embed/VuqeWMAga2Iw0" width="500" height="353" frameBorder="0" class="giphy-embed" allowfullscreen=""></iframe></div><p>When a recent<a href="https://www.reddit.com/r/AskReddit/comments/b0ox0w/children_of_i_want_to_talk_to_your_manager/"> Reddit </a>thread asked, &quot;Children of &#x27;I want to talk to your manager&#x27; parents, what has been your most embarrassing experience?&quot; the internet was ready to share their most cringe-worthy, secondhand shameful moments. Get ready to give up on humanity, these parents should be canceled. </p><p><strong>1. You mom needs anger management, &quot;elsoov.&quot; </strong></p><blockquote> <p>I was 13 when this happened. My mom had made a reservation at a hotel for a trip, but when she got there the lady said there was some error with the reservation and that my mom’s payment didn’t go through, so the lady offered us a double bed room for a discount.</p> <p>Rather than just taking the room, thanking the lady, and leaving, my mom decided the best course of action would be to scream, in the middle of a hotel lobby, “NOBODY IS GOING ANYWHERE TIL I GET MY FUCKING ROOM!” She then proceeded to pester the lady, who clearly couldn’t do anything about it, until eventually she called the police on my mom for public disturbance. Mortifying.</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p><strong>2. Napkins are important, &quot;snopal.&quot; </strong></p><blockquote> <p>Not my parent but grandparent. When I was around 10 years old my grandmother went out and got us (her, my brother, and me) McDonald&#x27;s. We got home and we didn&#x27;t have napkins in the bags. No big deal, right? We have paper towels and napkins in the house, also me and my brother are pretty good with not making any messes while we eat.</p> <p>Nope. Grandmother got us in the car, drove back to McDonald&#x27;s, demanded a manager, and screeched about how upset she was that we didn&#x27;t get any napkins. I wanted to just melt into the floor and disappear. It&#x27;s just napkins, Nanny....</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p><strong>3. Oh my god, &quot;solus-esse-nolo.&quot; </strong></p><blockquote> <p>My Mum demanded to see a café&#x27;s hygiene certificate when she saw an employee go from cutting cake in the kitchen to handling money at the till, even though the real problem is going the other way.</p> </blockquote><p><strong>4. The floor is gross, though, &quot;ohhellnoxd.&quot; </strong></p><blockquote> <p>When I was a young child on a long distance flight my mother let me and my brother sleep on the floor. For safety reasons the flight attendants told my mother that we were not allowed to sleep on the floor. She started to argue with the flight attendants who then turned to the pilots. The pilots threatened to turn the plane around unless we get up from the floor but she continued to argue. The pilots anounced they were about to turn around because of my mother, so all the passangers got pissed. Eventually she caved in when she had all passengers and flight crew on a boeing 747 against her..</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p><strong>5. Oh no, &quot;psychswot.&quot; </strong></p><blockquote> <p>I was with my parents on vacation and the hotel put charges on the bill by accident. My mom marched to the front desk and demanded to see the manager. There was a long line, but she cut right in front of it. The manager wasn&#x27;t very helpful, probably because she was rude.</p> <p>So my mom, went to all the other customers in line and told them that the hotel was a scam and they were ripping us off with fake charges. She made a scene. The hotel called the police and we were escorted off the premises by actual cops. I died inside.</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p><strong>6. Ok this sounds like low key assault of a minor, &quot;cok3noic3.&quot; </strong></p><blockquote> <p>Ugh, my dad. He can be such a prick if you get his order wrong, it could be fast food or a nice sit down restaurant. He often yells at wait staff if they “undercook” his steak. It has to be well done or he claims to have lost his appetite.</p> <p>One time we went to Burger King when I was younger and we sat down to eat. He took one bite of his burger, spit it out and immediately started bitching about it being under cooked. He cut in front of everyone in line to yell at the cashier, then he asked who was the cook. when the cook appeared, he launched his burger hitting the poor kid directly in the face with a lidless burger. He’s now banned for life from Burger King</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p><strong>7. Absolutely not, &quot;BigDaddy0790.&quot; </strong></p><blockquote> <p>My mom asked me to call her a taxi via an app.</p> <p>She ended up calling me multiple times complaining about how the driver didn’t use the route she thought was best (she never owned a car and doesn’t know how to drive), even though the guy just used the best possible route the navigator suggested.</p> <p>She ended up getting out halfway and using subway. The driver proceeded to call me in tears, completely shocked, unsure of what he did so wrong, and apologizing. I felt like total shit.</p> <p>I never called her a cab again.</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p><strong>8. WTF, &quot;pootermun.&quot; </strong></p><blockquote> <p>I might be late but my dad once asked the guy at the verizon wireless store to give him his own Social Secuirity number because he asked for my dads. My dad walked out afterwards with some strangers SS number on a post it. I was a silent bystander because I really wanted my first phone.</p> </blockquote><p><strong>9. Damn, &quot;johnlonger.&quot; </strong> </p><blockquote> <p>My father consistently returns food to grocery stores when he is unsatisfied with the quality. The worst is when he returns the 2lb bricks of cheddar cheese because they went moldy &quot;before they should have&quot;</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p><strong>10. This is probably the worst one, &quot;sixstringhook.&quot; </strong></p><blockquote> <p>Not me, but my sister in law. Her step dad and mom took the family out to eat at a Red Lobster. They get there and it is super busy. So the step dad walks up to the host and says &quot;Yes, we have a reservation&quot;.</p> <p>The problem is, Red Lobster (or at least that one) doesnt take reservations. The host explains this and says it is going to be 20 min wait for seating. Her step dad FLIPPED out and started screaming that he had called 3 hours before hand and made a reservation. The host politely told him this was not possible as they do not take reservations (again).</p> <p>He continues to scream at the guy, and says he wants to talk to a manager. So the manager comes out and she tells him the same thing. They dont take reservations, so its not possible that he had made one. He continues to cause a scene and people started leaving just to get away from this toxic guy. Finally, the manager says, &quot;Fine, we will put you ahead of everyone else that has been patiently waiting their turn&quot;. He says &quot;Thank you&quot;. They get seated.</p> <p>Once they get to the table and the waitress walks away, he slyly winks and says to my brother and the rest of the family &quot;THAT is how you get things done. I wasnt going to wait 20 min&quot;.</p> <p>My brother refused to eat or order for fear of getting food that had been spit on.</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p><strong>11. Wow, &quot;RixxiRose.&quot; </strong></p><blockquote> <p>My MIL is truly a Karen. Going out to eat with her is always a nightmare. Her orders have 14 special requests, but she&#x27;s not at all kind about it, she is defensive from the get go like you&#x27;re an idiot who&#x27;s already screwed the order up. &quot;Nooo dressing. Not on the side. Nothing. Completely dry. Do you understand? I will send it back!&quot;</p> <p>The one I will never forget though was dinner at Joe&#x27;s Crab shack. In case you&#x27;ve never been it&#x27;s one of those places that every so often plays a song that the entire staff is required to drop everything &amp; do a little synchronized dance to. It&#x27;s quick, everyone gets a little kick out of it, it&#x27;s part of the fun. Now my MIL Karen knew this, it&#x27;s not like she&#x27;d never been here. But apparently she was not willing to wait 2 extra minutes for her dry salad, so she starts going off as soon as the dancing starts. She gets a manager, who clearly knows Karen well &amp; offers a quick apology (for doing their job), a discount &amp; her dry ass salad. But Karen&#x27;s not completely satisfied. She tells us that even though dinner for our party of 8 is on her, she&#x27;s not tipping the waitress 1 penny. She proceeds to bitch.....loudly...the rest of the meal &amp; antagonize our waitress over petty shit.</p> <p>I worked too many years in customer service &amp; ya know, I&#x27;m a decent human being. I made sure to get my bill separate so I could tip for the entire table. I wrote a quick note on the receipt, something along the lines of &quot;Way to stay positive even when the customer&#x27;s a jerk&quot;. I was a little afraid of the wrath of Karen, it was one of my first interactions with her too, but when the waitress came &amp; hugged me, Karen &amp; I locked eyes. She knew. I didn&#x27;t care. Don&#x27;t be a cunt Karen.</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p><strong>12. Gotta have A1, &quot;Streaks-&quot;</strong></p><blockquote> <p>When I was 6 my mom took my brothers and I out to Golden Corral for dinner. She went up to the buffet, got a steak, and came back to the table. She’s an avid A1 steak sauce fan and cannot, i repeat, cannot eat steak without it.</p> <p>She poured out the A1 onto her plate, tasted it, and was instantly horrified. She proceeded to pour out the Golden Corral Steak Sauce right next to the A1 and it matched perfectly.</p> <p>Outraged, she called over a waitress and eventually the manager showing them her little experiment and how she exposed the Great Steak Sauce Fraud of 06.</p> <p>My brothers and I were scarred for the rest of our lives. I still have nightmares about it.</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p>13. <strong>This is so sad, &quot;FuzzyElf47.&quot; </strong></p><blockquote> <p>The number of cashiers my father demanded the manager fire because they were too slow, rang us up wrong, etc, including one they actually <em>did.</em> I&#x27;ll never forget that girl taking her Home Depot apron off and walking away sobbing. To his credit (I guess?) my dad seemed surprised that it actually worked, must have felt at least some level of guilt and never did it again.</p> </blockquote><p><strong>14. You&#x27;re an angel, &quot;Lurkist.&quot; </strong></p><blockquote> <p>I don&#x27;t like going to restaurants with her, she thinks that because she worked as a waitress for a year 35 years ago, it gives her the right to act like a complete asshole to them. She also thinks not tipping them will encourage them to &quot;get their act together&quot;. Jokes on you mom, I always find our server after seated, give them a $20.00 and apologize in advanced for your poor behavior.</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p>15. <strong>A+, &quot;n8spear.&quot; </strong></p><blockquote> <p>My mom used to run restaurants. My step father used to be a chef in high end restaurants and is the kind of guy who expects to be treated better than he is currently being treated, regardless of whatever that treatment is. They are not fun to go out to eat with.</p> <p>The “most embarrassing experience” is actually their most embarrassing experience, one where I Embarrassed them.</p> <p>My wife and I pride ourselves on being a “relief” table when we go out to eat. Both of us have been servers, and there’s always the counterpoint to the difficult table, that’s us. Barring horrible service or bad food, we are super easy customers, tip well, and try to have a good time with our server. Furthermore, we just treat people nicely. So you can imagine our distain when my parents act like they’re fucking royalty at a dinner service.</p> <p>My wife and I went out to dinner with them. They were being particularly tough. My mom was acting like she was Gordon Ramsey analyzing the business, critiquing everything down to the amount of bubbles in her seltzer (“looks like it’s time to change the CO2”) My step dad was getting more and more heated over stupid things like the amount of ice in his drink and how the waitress didn’t top off his water, that he was barely sipping on, fast enough.</p> <p>It came to a head when my step father ordered a steak medium well, it came back medium well, and for some reason he changed his mind that he wanted it medium rare while it was cooking and they didn’t read his mind, so he gave attitude, as did my mom. They jumped really quickly to demanding free stuff.</p> <p>I’m an adult and this may be the first time they realized this. I interrupted in front of the server and said something like “really? This is what you’re doing. That’s what you ordered...” I turned to the server and said “We do not need anything comped.” I then pulled out my wallet and handed her my card and said “this is for the bill. We’ll happily wrap up with what we have here. I’m very sorry for their behavior, you’re doing great.” Then the line that stung them so deep they still bring it up years later ...”I was taught to treat people nicely, a lesson that seems to be forgotten. Thank you.”</p> <p>They turned red, the server walked away, I looked down and cut my steak, and didn’t say a word. They were so flabbergasted that the meal was virtually silent except me asking my step father how his steak was a few minutes later. I signed the check, gave a big tip, and we walked out and said goodbyes.</p> <p>They’ve been nicer to servers each time that we’ve gone out since.</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p><strong>16. Damn, &quot;s8erguyssk8er.&quot; </strong></p><blockquote> <p>My mom has been this person regularly throughout my life but I do have one positive story with it.</p> <p>She and I went to eat at portillo&#x27;s when I was a teenager and we sat in the back of the restaurant where it was more private so we can eat in peace. About 10 minutes into our meal two people come into the empty area and sit down two tables away from us. Turns out it was a manager and an employee that was getting written up. the manager was being a complete asshat towards the employee criticizing and belittling them. My mom put down her food and walked over and started yelling at the manager for being such an asshole. she went on a rant about how rude and wrong it was of him to do this in front of the public two tables away from customers and really let him have it. She demanded the phone number of the manager above him and we left after she received it. I was pretty embarrassed at the time but as I got older I realized that she was standing up for that employee and how wrong that manager really was. I&#x27;m not a hundred percent sure what she did with that phone number because I lived with my dad and I had to go home after that meal.</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p><strong>17. Aw, &quot;WaulsTexLegion.&quot; </strong></p><blockquote> <p>It was at a TGI Fridays in Katy, TX. This waiter was amazing. He was working 8 tables that I could count and was managing all of them flawlessly. Drinks never got below 1/3rd full at any table, he was always attentive and prompt, friendly, just a textbook example of the perfect waiter. He impressed my dad so much that my dad asked if he could speak to a manager. Of course, the waiter immediately asks if anything is wrong, since that&#x27;s the only time someone asks. My dad tells him no, it&#x27;s to make sure that management knows what excellent service he&#x27;s providing. The waiter thanks us and says he&#x27;ll get a manager over as quickly as he can.</p> <p>We wait for about 10 minutes before this middle-aged grease ball of a manager saunters over and starts asking my dad how the waiter screwed up. My dad is not the most patient of people, and we were kinda in a hurry to get home, so the 10 minute wait was rubbing him wrong. But when the manager immediately acted like the guy was a screw up, my dad lost it. He told the manager that the waiter had done everything perfectly, and that&#x27;s why he tipped the guy $15 on a $35 ticket. He also went on to say that the manager needed to be more respectful of his staff and gave the guy an ass chewing for presuming that the employee had screwed up. Before that moment, I thought that my sister and I were the only ones he would scream at when he was upset. It was somewhat embarrassing to see my dad yell at this guy, but he did it for a good reason.</p> </blockquote> </span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><span> <p> </p></span><div class="ad-container-responsive"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label">Advertising</div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div><div class="ds-bottom" id="ds_default_anchor"></div><div class="post-footer-container"><div class="copyright-container">© Copyright 2019 Someecards, Inc</div></div></div><hr /><div class="outbrain-wrapper"><div class="OUTBRAIN" data-src="https://www.someecards.com/news/news/18-people-with-i-want-to-talk-to-your-manager-parents-reveal-their-most-embarrassing-moments/" data-widget-id="AR_1" data-ob-template="SomeEcards"></div></div></div><div class="post-right-outer"><div class="post-right-inner"><div class="ds-right" id="ds_default_anchor"><div class="ad-container-responsive right-side-ad"><div class="ad-pre"></div><div class="ad-inner"><div class="ad-label"> </div><div class="ad-wrapper"><span style="font-size:0"></span></div></div><div class="ad-post"></div></div></div></div></div></div></div><div class="container bottom-of-post"></div><div class="slider-container"></div></div></div></div></div></div><script nonce="e7449cb3-7136-49d0-b877-f16cbf210b56" type="text/javascript">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</script><script type="text/javascript" nonce="e7449cb3-7136-49d0-b877-f16cbf210b56">window.__CLIENT_CONFIG__={"welcomeMessage":"Hello world!","serviceWorker":{"enabled":false},"polyfillIO":{"enabled":true,"url":"\u002F\u002Fcdn.polyfill.io\u002Fv2\u002Fpolyfill.min.js","features":["default","es6"]},"htmlPage":{"titleTemplate":"Someecards.com - %s","defaultTitle":"Loading...","description":"Get a funny take on today's popular news, entertainment, lifestyle, and video content -- all written by the people who bring you those funny ecards.","keywords":"someecards.com,some ecards,someecards,some ecards.com,Online Greetings,card,ecards,greeting cards,greetings,electronic cards,e cards,e-cards,electronicgreetings,email cards,e-mail,email,postcard,electronic postcard,animated greetings,holidays,funny holiday cards,funny birthday cards,funny friendship ecards,funny hello ecards,funny get well ecards,funny business ecards,funny thank you ecards,funny anniversary ecards,funny congratulations ecards,funny graduation ecards,funny wedding ecards,funny love ecards,funny romance ecards,funny new baby ecards,funny sorry ecards,funny thinking of you ecards,funny sympathy ecards,funny belated birthday ecards,funny invitations ecards,funny new job ecards,funny retirement ecards,funny moving ecards,funny good luck ecards,funny reminder ecards"},"gaId":"UA-1329770-2","chartbeat":{"uid":35,"domain":"someecards.com"},"comscore":{"c1":2,"c2":8259767},"quantcast":{"qacct":"p-880wF3y-pNyF6"},"facebook":{"app_id":"32911495680"},"recaptcha":{"sitekey":"6LfJ-zQUAAAAAD2cdNWPLOem64bnYYuymhcfAKrT"},"apiBaseUrl":"https:\u002F\u002Fnapi.someecards.com","sessionCookie":"_SESSLoggedIn","cdnBaseUrls":{"staffCards":"https:\u002F\u002Fcdn.someecards.com\u002Fsomeecards\u002Ffilestorage\u002F","userCards":"https:\u002F\u002Fcdn.someecards.com\u002Fsomeecards\u002Fusercards\u002F","posts":"https:\u002F\u002Fcdn.someecards.com\u002Fposts\u002F","users":"https:\u002F\u002Fcdn.someecards.com\u002Fusers\u002F","tags":"https:\u002F\u002Fcdn.someecards.com\u002Ftags\u002F","polls":"https:\u002F\u002Fcdn.someecards.com\u002Fpolls\u002F","assets":"https:\u002F\u002Fcdn.someecards.com\u002Fassets\u002F","sections":"https:\u002F\u002Fcdn.someecards.com\u002Fmicrosites\u002F","weather":"https:\u002F\u002Fcdn.someecards.com\u002Fweather\u002F"},"embedDomains":["someecards.com","www.someecards.com","dev.someecards.com","uat.someecards.com","local.someecards.com"],"firebase":{"apiKey":"AIzaSyBxQoAlulKYx7lMLtRvl-G_H0YoCoP-bPk","authDomain":"mitch.firebaseapp.com","databaseURL":"https:\u002F\u002Fmitch.firebaseio.com","projectId":"mitch-188215","messagingSenderId":"532158790744"}}</script><script nonce="e7449cb3-7136-49d0-b877-f16cbf210b56" type="text/javascript">window.__ASYNC_COMPONENTS_REHYDRATE_STATE__={"resolved":{"1":true}};</script><script nonce="e7449cb3-7136-49d0-b877-f16cbf210b56" type="text/javascript">window.__JOBS_STATE__={"jobs":{"1":{"data":true},"2":{"data":true}}}</script><script nonce="e7449cb3-7136-49d0-b877-f16cbf210b56" type="text/javascript">window.__ROUTER_STATE__={}</script><script type="text/javascript" src="//cdn.polyfill.io/v2/polyfill.min.js?features=default,es6"></script><script type="text/javascript" src="https://assets.someecards.com/build/client/index-c994aadd7bcd2b4ee6dd.js"></script><script data-react-helmet="true" type="application/ld+json">
            {
              "@context": "http://schema.org",
              "@type": "NewsArticle",
              "mainEntityOfPage": {
                "@type": "WebPage",
                "@id": "https://www.someecards.com/news/news/18-people-with-i-want-to-talk-to-your-manager-parents-reveal-their-most-embarrassing-moments/"
              },
              "headline": "18 people with 'I want to talk to your manager' parents reveal their most embarrassing moments. | Someecards News",
              "image": {
                "@type": "ImageObject",
                "url": "https://cdn.someecards.com/posts/18-people-with-i-want-to-talk-to-your-manager-parents-reveal-their-most-embarrassing-moments-RhK.jpg",
                "height":525,
                "width":1000
              },
              "datePublished": "2019-03-14T18:11:53Z",
              "dateModified": "2019-03-14T19:36:03Z",
              "author": [{"@type":"Person","name":"Kimberly Dinaro"}],
              "publisher": {
                "@type": "Organization",
                "name": "Someecards",
                "logo": {
                  "@type": "ImageObject",
                  "url": "http://cdn.someecards.com/assets/images/header/header-logo-mobile@2x.png",
                  "width": 267,
                  "height": 60
                }
              },
              "description": "18 people with 'I want to talk to your manager' parents reveal their most embarrassing moments."
            }
          </script><script data-react-helmet="true" async="" type="text/javascript" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script data-react-helmet="true" async="" type="text/javascript" src="//c.jsrdn.com/s/cs.js?p=22626"></script><script data-react-helmet="true">
            (adsbygoogle = window.adsbygoogle || []).push({
              google_ad_client: "ca-pub-5359145841079630",
              enable_page_level_ads: true
            });
            </script></body></html>